21 lines
676 B
Nix
21 lines
676 B
Nix
inputs: final: prev: {
|
|
wgautomesh = let
|
|
toolchain = inputs.fenix-monthly.packages.${final.stdenv.hostPlatform.system}.latest.toolchain;
|
|
cargo = toolchain;
|
|
platform = final.makeRustPlatform {
|
|
rustc = toolchain;
|
|
cargo = toolchain;
|
|
};
|
|
wgam-nightly = prev.wgautomesh.override {rustPlatform = platform;};
|
|
wgam-lyn = wgam-nightly.overrideAttrs (old: rec {
|
|
src = builtins.fetchGit {
|
|
url = "https://git.deuxfleurs.fr/lynatic/wgautomesh.git";
|
|
rev = "7f844a2f5d67f788c3b2084fb3ab0c25b10928cc";
|
|
};
|
|
cargoDeps = platform.importCargoLock {
|
|
lockFile = src + "/Cargo.lock";
|
|
};
|
|
});
|
|
in
|
|
wgam-lyn;
|
|
}
|